Forums slow?

Suggestions, complaints and news about coffeeshopdirect.com
Post Reply
User avatar
Lemming
Site Admin
Posts: 3464
Joined: Sat 5th Mar 2005 07:17 am
Location: UK
Contact:

Forums slow?

Post by Lemming »

Has anyone else found that logging in, opening topics etc. has been very sluggish over the past few days? I'm wondering whether it's a problem in my house or at the server.
User avatar
Not_the_monk
Posts: 970
Joined: Wed 22nd Aug 2012 02:22 am

Re: Forums slow?

Post by Not_the_monk »

Yes, I thought it really was quite sluggish maybe a day or two ago. Seems more like normal right now however.
User avatar
jiffa
Posts: 123
Joined: Fri 4th Jan 2013 10:08 pm
Location: Somewhere in my mind

Re: Forums slow?

Post by jiffa »

Its lagging a bit when opening up, thought it was just me :lol:
Jail for growing a plant laughed the gypsy!
User avatar
Lemming
Site Admin
Posts: 3464
Joined: Sat 5th Mar 2005 07:17 am
Location: UK
Contact:

Re: Forums slow?

Post by Lemming »

Seems like we have some kind of database issue.
I'm busy for the next couple of days so hope it doesn't get any worse.
I'll look into it after that.
User avatar
Lemming
Site Admin
Posts: 3464
Joined: Sat 5th Mar 2005 07:17 am
Location: UK
Contact:

Re: Forums slow?

Post by Lemming »

I still don't know what's going on here.

It seems that the problem started around 22nd May. From that date onwards the forums have been maxing out the permitted amount of CPU capacity. When it hits the max it gets capped and that's what causes the delays.

The question is why it's suddenly using so much processor power. It's not a particularly power hungry application and the number of users hasn't increased dramatically since 22 May.

The server company are convinced that it's a software issue but, as far as I know, nothing changed around 22 May. They updated the PHP (the software platform that the phpBB forum software runs on top of). That briefly broke the forum altogether yesterday but they've sorted that now. I'll update the phpBB software soon because there is a new version available but I'm not convinced that's the cause.

For some reason it hasn't been maxing out over the past couple of hours. Again, I'm not aware of anything changing. Fingers crossed it stays this way.
User avatar
Lemming
Site Admin
Posts: 3464
Joined: Sat 5th Mar 2005 07:17 am
Location: UK
Contact:

Re: Forums slow?

Post by Lemming »

This is still going on and still mystifying me.
User avatar
Lemming
Site Admin
Posts: 3464
Joined: Sat 5th Mar 2005 07:17 am
Location: UK
Contact:

Re: Forums slow?

Post by Lemming »

This remains bizarre but has changed a little.

I tried updating the phppBB software to the latest version and also blocked a few robots - notably Facebook - but none of that seemed to make any difference. The number of guests viewing the forums dropped dramatically but the madness on the server remained the same.

Then, a few days ago, the problem mysteriously largely stopped. No idea why. Weirdly it still happens for an hour or so around about 1am UK time every night. I can't see anything special about the activity on the forums around that time and the server company have no idea either.
Post Reply